The OpenVPN client of the Teltonika router only shows ‘Disconnected’ after a fw update

Problem:

After updating the firmware on a Teltonika (RUT240, RUT950, or RUT955) with an OpenVPN client (e.g., mdex fixed.IP/public.IP), the OpenVPN client shows "Disconnected" status, despite the connection being active. See example below:

 

Cause:

The OpenVPN status parameters have changed in newer firmware versions, and the update did not convert or remove these parameters correctly.

 

Solution:

This is only a display error in the WebUI, which has no influence on functionality. To correct this display problem, some UCI commands must be executed to delete the status parameters that are no longer required. This can be done either locally via CLI or SSH or alternatively remotely. The following is a method using a startup script via the WebUI:

  1. Log into the router's WebUI using a browser.
  2. Under System > Maintenance > Custom Scripts, add the following commands
    /sbin/uci delete openvpn.fixedIP.status
    /sbin/uci delete openvpn.publicIP.status
    /sbin/uci commit
    and click 'Save & Apply':
  3. Trigger a reboot so that the commands in the startup script are executed.
  4. After rebooting, remove the commands from System > Maintenance > Custom Scripts and click 'Save & Apply':
  5. Once the OpenVPN connection is disconnected and reconnected (e.g. by rebooting the router again), the status will correctly show as "Connected":

 

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