Problem:
Bei einem Teltonika (RUT240, RUT950 oder RUT955) mit OpenVPN-Client (z.B. mdex fixed.IP/public.IP) wurde ein Firmware-Update von einer älteren Version auf die aktuelle Version durchgeführt. Seit diesem Update zeigt der OpenVPN-Client jedoch nur noch den Status "Disconnected" an, obwohl die OpenVPN-Verbindung tatsächlich hergestellt wurde. Ein Beispiel hierfür sehen Sie hier:
Ursache:
Bei neueren Firmware-Versionen haben sich die OpenVPN-Statusparameter geändert. Im Zuge des Firmware-Updates wurden die OpenVPN-Statusparameter jedoch nicht ordnungsgemäß konvertiert, bzw. entfernt.
Lösung:
Es handelt sich hierbei lediglich um einen Anzeigefehler in der WebUI, der jedoch keinen Einfluss auf die Funktionalität hat. Um dieses Anzeigeproblem zu beheben, müssen einige UCI-Befehle ausgeführt werden, damit die nicht mehr erforderlichen Status-Parameter gelöscht werden. Dies kann entweder lokal per CLI oder SSH oder alternativ remote erfolgen. Nachfolgend ist eine Methode per Startup-Skript über die Weboberfläche (WebUI) beschrieben:
- Loggen Sie sich mit einem Browser in die Weboberfläche (WebUI) des Routers ein.
- Fügen Sie unter System > Maintenance > Custom Scripts die folgenden Befehle
/sbin/uci delete openvpn.fixedIP.status
hinzu und klicken Sie auf 'Save & Apply':
/sbin/uci delete openvpn.publicIP.status
/sbin/uci commit - Führen Sie einen Neustart (Reboot) des Routers durch, damit die Befehle im Startup Script ausgeführt werden:
- Nach dem Neustart entfernen Sie die Befehle unter System > Maintenance > Custom Scripts und klicken auf 'Save & Apply'.
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Sobald die OpenVPN-Verbindung erneut getrennt und wiederhergestellt wird, beispielsweise durch einen weiteren Neustart des Routers, wird die OpenVPN-Statusanzeige korrekt als "Connected" angezeigt: